blob: ae64559607663a20387803f00a8c14301a379a7f [file] [log] [blame]
# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b773f48488a50bc8361a6f2cf9938e418eccf434"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "33de53739dbe0fd2911d58694b622539ef0a2416" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk verity .gn"
PLATFORM_SUBDIR="verity"
inherit cros-workon platform
DESCRIPTION="File system integrity image generator for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/verity/"
LICENSE="BSD-Google GPL-2"
KEYWORDS="*"
src_install() {
dobin "${OUT}"/verity
dolib.so "${OUT}"/lib/libdm-bht.so
insinto "/usr/$(get_libdir)/pkgconfig"
doins libdm-bht.pc
insinto /usr/include/verity
doins dm-bht.h dm-bht-userspace.h file_hasher.h
cd include || die
doins -r asm-generic
}
platform_pkg_test() {
platform_test "run" "${OUT}/verity_tests"
}