blob: 8a1f849d6436c745655c50138181c683a9da579a [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("86174eb4f146aed6d1f5182351f7ed3a25629823" "375fa7a2d8b977c1744f288d0e6b0e4592e2ebbc")
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "8147e94e7ebea6c5e875e4722b2e064d0ba861c4")
CROS_WORKON_LOCALNAME=("platform2" "aosp/system/update_engine")
CROS_WORKON_PROJECT=("chromiumos/platform2" "aosp/platform/system/update_engine")
CROS_WORKON_EGIT_BRANCH=("main" "master")
CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/update_engine")
CROS_WORKON_USE_VCSID=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE=("common-mk .gn" "")
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="update_engine/client-headers"
inherit cros-debug cros-workon platform
DESCRIPTION="Chrome OS Update Engine client library"
HOMEPAGE="https://chromium.googlesource.com/aosp/platform/system/update_engine/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="cros_host"
RDEPEND="
!<chromeos-base/update_engine-0.0.3
"
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "update_engine"
}