blob: 5caaa334969ae355fc36b364cdb9afb152c59ee3 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
# TODO(crbug.com/809389): remove 'metrics' pulled in from header dependency.
CROS_WORKON_SUBTREE="common-mk screen-capture-utils metrics .gn"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
PLATFORM_SUBDIR="screen-capture-utils"
inherit cros-workon platform
DESCRIPTION="Utilities for screen capturing"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/screen-capture-utils/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
# Mark the old screenshot package as blocker so it gets automatically removed in
# incremental builds.
RDEPEND="
chromeos-base/metrics
!chromeos-base/screenshot
media-libs/libpng:0=
media-libs/minigbm:=
net-libs/libvncserver
x11-libs/libdrm:=
virtual/opengles"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers"
src_install() {
dosbin "${OUT}/kmsvnc"
dosbin "${OUT}/screenshot"
}