blob: b3d7952d5e84f2e774d7ba1d4254638da877968d [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="6f9011123f3656c45bb34148673aa110a22326b3"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "517c3fdaddc3179ddb87307a44118265bb0c00c3" "20d593bc4f76d08b642ac2d57ed2f4f9af04ce50" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk ml ml_benchmark .gn"
PLATFORM_SUBDIR="ml"
inherit cros-workon platform
DESCRIPTION="Command line interface to machine learning service for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/ml"
LICENSE="BSD-Google"
KEYWORDS="*"
SLOT="0/0"
IUSE="internal"
RDEPEND="
chromeos-base/chrome-icu:=
>=chromeos-base/metrics-0.0.1-r3152:=
chromeos-base/ml:=
sci-libs/tensorflow:=
"
DEPEND="
${RDEPEND}
"
src_install() {
dobin "${OUT}"/ml_cmdline
}
platform_pkg_test() {
platform_test "run" "${OUT}/ml_cmdline_test"
}