blob: fa6aa63c4c24202e38bf15fcb8e51807307f77ad [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "92250239305f99e58bf74de7db462c841dfa3c4b" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk foomatic_shell .gn"
PLATFORM_SUBDIR="foomatic_shell"
inherit cros-workon platform
DESCRIPTION="Mini shell used by foomatic-rip to execute scripts in PPD files."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/foomatic_shell/"
LICENSE="BSD-Google"
KEYWORDS="*"
src_install() {
dobin "${OUT}/foomatic_shell"
# Install fuzzer
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/foomatic_shell_fuzzer
}
platform_pkg_test() {
platform_test "run" "${OUT}/foomatic_shell_test"
}