blob: 79b4e9a4c5473007fbfdbcc04c0f1bbdca4523b0 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "e8023258ebab0150d1674664c16f6d197136cc8b" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-dbus-bindings .gn"
PLATFORM_SUBDIR="${PN}"
PLATFORM_NATIVE_TEST="yes"
inherit cros-workon platform
DESCRIPTION="Utility for building Chrome D-Bus bindings from an XML description"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/chromeos-dbus-bindings"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="
dev-libs/expat
sys-apps/dbus"
DEPEND="${RDEPEND}"
src_install() {
dobin "${OUT}"/generate-chromeos-dbus-bindings
}
platform_pkg_test() {
platform_test "run" "${OUT}/chromeos_dbus_bindings_unittest"
}