blob: d11eb8658590a5c3c29a668e3484e0bd2a57a813 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "63862a9eebc1145ee434295657abeeefaf884645" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_SUBTREE="common-mk cfm-dfu-notification .gn"
CROS_WORKON_DESTDIR="${S}/platform2"
PLATFORM_SUBDIR="cfm-dfu-notification"
inherit cros-workon platform
DESCRIPTION="Library to send firmware update notifications to CFM"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
RDEPEND=""
DEPEND="${RDEPEND}"
src_install() {
dolib.so "${OUT}"/lib/libcfm_dfu_notification.so
"${S}"/platform2_preinstall.sh "${PV}" "/usr/include/chromeos" "${OUT}"
insinto "/usr/$(get_libdir)/pkgconfig"
doins "${OUT}"/cfm-dfu-notification.pc
insinto "/usr/include/chromeos/cfm-dfu-notification"
doins ./*.h
}
platform_pkg_test() {
platform_test "run" "${OUT}"/cfm_dfu_notification_test
}