blob: c5f9724cd3939d7e5306efb648d2f514d503f1fd [file] [log] [blame]
# Copyright 2019 The ChromiumOS Authors
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="4cd35fb11ce1d94e91ded61681327ee6738c3578"
CROS_WORKON_TREE=("1647a468f15f85e89d45c799e27359e3e664c67b" "7a325f49c4f6a99fe834186bd9e7a550595ca033" "bdc2fe06e72f494e59d3000e9c660943df59f82c" "d60fbd9fd8eba6e1fecd04816242b111eb1c36ef" "41112b3759d18a5cceaf1f06f65e6d4bdc406e33" "035e5f57815742ad6e80d8821e81f18e0fcaa4f7" "199cac0899daace8030b33f49dd183a5b5baf169" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libhwsec libhwsec-foundation metrics tpm_manager tpm2-simulator trunks .gn"
PLATFORM_SUBDIR="libhwsec"
inherit cros-workon platform
DESCRIPTION="Crypto and utility functions used in TPM related daemons."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/libhwsec/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test fuzzer tpm tpm2 tpm_dynamic"
COMMON_DEPEND="
chromeos-base/chromeos-ec-headers:=
chromeos-base/libhwsec-foundation:=
chromeos-base/metrics:=
chromeos-base/tpm_manager-client:=
dev-libs/openssl:0=
dev-libs/flatbuffers:=
tpm2? (
chromeos-base/pinweaver:=
chromeos-base/trunks:=[test?]
)
tpm? ( app-crypt/trousers:= )
fuzzer? (
app-crypt/trousers:=
chromeos-base/trunks:=
)
test? (
app-crypt/trousers:=
chromeos-base/pinweaver:=
chromeos-base/trunks:=[test]
chromeos-base/tpm2-simulator:=[test]
)
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
platform_pkg_test() {
platform test_all
}