blob: de254bf8814c7daacf26a0fa85d6673d5e6c1684 [file] [log] [blame]
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
GNOME2_LA_PUNT="yes"
inherit flag-o-matic gnome2 multilib multilib-minimal autotools cros-sanitizers
DESCRIPTION="Image loading library for GTK+"
HOMEPAGE="https://git.gnome.org/browse/gdk-pixbuf"
LICENSE="LGPL-2+"
SLOT="2"
KEYWORDS="*"
IUSE="X debug +introspection jpeg jpeg2k tiff test"
# Remove SRC_URI when gnome bug #795069 is fixed
SRC_URI="${SRC_URI} test? ( https://git.gnome.org/browse/gdk-pixbuf/plain/tests/bug753605-atsize.jpg?h=2.36.12 -> ${PN}-2.36.12-bug753605-atsize.jpg )"
COMMON_DEPEND="
>=dev-libs/glib-2.48.0:2[${MULTILIB_USEDEP}]
>=media-libs/libpng-1.4:0=[${MULTILIB_USEDEP}]
introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
jpeg? ( virtual/jpeg:0=[${MULTILIB_USEDEP}] )
jpeg2k? ( media-libs/jasper:=[${MULTILIB_USEDEP}] )
tiff? ( >=media-libs/tiff-3.9.2:0=[${MULTILIB_USEDEP}] )
X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
"
DEPEND="${COMMON_DEPEND}
dev-util/glib-utils
>=dev-util/gtk-doc-am-1.20
>=sys-devel/gettext-0.19
virtual/pkgconfig
"
# librsvg blocker is for the new pixbuf loader API, you lose icons otherwise
RDEPEND="${COMMON_DEPEND}
!<gnome-base/gail-1000
!<gnome-base/librsvg-2.31.0
!<x11-libs/gtk+-2.21.3:2
!<x11-libs/gtk+-2.90.4:3
"
MULTILIB_CHOST_TOOLS=(
/usr/bin/gdk-pixbuf-query-loaders$(get_exeext)
)
PATCHES=(
# Do not run lowmem test on uclibc
# See https://bugzilla.gnome.org/show_bug.cgi?id=756590
"${FILESDIR}"/${PN}-2.32.3-fix-lowmem-uclibc.patch
"${FILESDIR}"/thumbnailer-cross-compile.patch
)
src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=795069
if use test ; then
cp -v "${DISTDIR}"/${P}-bug753605-atsize.jpg "${S}"/tests/bug753605-atsize.jpg || die
fi
# This will avoid polluting the pkg-config file with versioned libpng,
# which is causing problems with libpng14 -> libpng15 upgrade
# See upstream bug #667068
# First check that the pattern is present, to catch upstream changes on bumps,
# because sed doesn't return failure code if it doesn't do any replacements
grep -q 'l in libpng16' configure || die "libpng check order has changed upstream"
sed -e 's:l in libpng16:l in libpng libpng16:' -i configure || die
[[ ${CHOST} == *-solaris* ]] && append-libs intl
gnome2_src_prepare
eautoreconf
}
multilib_src_configure() {
sanitizers-setup-env
# png always on to display icons
ECONF_SOURCE="${S}" \
gnome2_src_configure \
$(usex debug --enable-debug=yes "") \
$(use_with jpeg libjpeg) \
$(use_with jpeg2k libjasper) \
$(use_with tiff libtiff) \
$(multilib_native_use_enable introspection) \
$(use_with X x11) \
--with-libpng
# work-around gtk-doc out-of-source brokedness
if multilib_is_native_abi; then
ln -s "${S}"/docs/reference/${PN}/html docs/reference/${PN}/html || die
fi
}
multilib_src_install() {
# Parallel install fails when no gdk-pixbuf is already installed, bug #481372
MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install
}
pkg_preinst() {
gnome2_pkg_preinst
multilib_pkg_preinst() {
# Make sure loaders.cache belongs to gdk-pixbuf alone
local cache="usr/$(get_libdir)/${PN}-2.0/2.10.0/loaders.cache"
if [[ -e ${EROOT}${cache} ]]; then
cp "${EROOT}"${cache} "${ED}"/${cache} || die
else
touch "${ED}"/${cache} || die
fi
}
multilib_foreach_abi multilib_pkg_preinst
}
pkg_postinst() {
# causes segfault if set, see bug 375615
unset __GL_NO_DSO_FINALIZER
multilib_foreach_abi gnome2_pkg_postinst
# Migration snippet for when this was handled by gtk+
if [ -e "${EROOT}"usr/lib/gtk-2.0/2.*/loaders ]; then
elog "You need to rebuild ebuilds that installed into" "${EROOT}"usr/lib/gtk-2.0/2.*/loaders
elog "to do that you can use qfile from portage-utils:"
elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.*/loaders)"
fi
}
pkg_postrm() {
gnome2_pkg_postrm
if [[ -z ${REPLACED_BY_VERSION} ]]; then
rm -f "${EROOT}"usr/lib*/${PN}-2.0/2.10.0/loaders.cache
fi
}