blob: 51535360bf49013fb7e9feddc97136b5f945d961 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="6f559ce22c83d2ebe12c7858c107f2151e769879"
CROS_WORKON_TREE="a512623f58d26799fbdb37b7f168eb8fea826a86"
CROS_WORKON_PROJECT="chromiumos/third_party/toolchain-utils"
CROS_WORKON_LOCALNAME="toolchain-utils"
inherit cros-workon
DESCRIPTION="Compilation and runtime tests for toolchain"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/toolchain-utils/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
RDEPEND="
app-misc/pax-utils
dev-lang/python
sys-devel/binutils
"
src_install() {
local tc_dir="/usr/$(get_libdir)/${PN}"
local dit_dir="${tc_dir}/debug_info_test"
insinto ${tc_dir}
doins -r debug_info_test
fperms a+x ${dit_dir}/debug_info_test.py
dosym ${dit_dir}/debug_info_test.py /usr/bin/debug_info_test
newbin afdo_redaction/redact_profile.py redact_textual_afdo_profile
newbin afdo_redaction/remove_indirect_calls.py remove_indirect_calls
newbin afdo_redaction/remove_cold_functions.py remove_cold_functions
}