blob: d9dce77c1eb90cad04dbd30e190cb54fd651bc0c [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="bc1199918e73f3f810b2eeb5dc38e71a5914772a"
CROS_WORKON_TREE="056aa2ec54c99a4f1e14b29aa279ce4694bdddd0"
CROS_WORKON_PROJECT="chromiumos/third_party/u-boot"
CROS_WORKON_LOCALNAME="u-boot/files"
CROS_WORKON_SUBTREE="tools/dtoc"
PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
inherit cros-workon distutils-r1
DESCRIPTION="Dtoc tool (from U-Boot) for converting devicetree files to C"
HOMEPAGE="https://www.denx.de/wiki/U-Boot"
LICENSE="GPL-2"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-vcs/patman"
src_unpack() {
cros-workon_src_unpack
S+=/tools/dtoc
}