blob: 37ef963acbb55cab37aa31d98b3b043666e5c6a4 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b05e4a6b92b2cfe608b6cd8d5d37168680fc080e"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "bd13eabfc804c66584fba6988a8b836b170442d7" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk tpm2-simulator .gn"
PLATFORM_SUBDIR="tpm2-simulator"
inherit cros-workon platform user
DESCRIPTION="TPM 2.0 Simulator"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/tpm2-simulator/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
COMMON_DEPEND="
dev-libs/openssl:0=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="
chromeos-base/tpm2:=
${COMMON_DEPEND}
"
src_install() {
dobin "${OUT}"/tpm2-simulator
}