blob: 8fb8fa0898c6daec5dc106def057849eb1ff50a8 [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
# $Header$
EAPI="7"
CROS_WORKON_PROJECT="chromiumos/platform/tpm"
CROS_WORKON_LOCALNAME="../third_party/tpm"
inherit cros-sanitizers cros-workon toolchain-funcs
DESCRIPTION="Various TPM tools"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tpm/"
LICENSE="BSD"
SLOT="0/0"
KEYWORDS="~*"
IUSE="-asan"
RDEPEND="app-crypt/trousers:="
DEPEND="${RDEPEND}"
src_configure() {
sanitizers-setup-env
default
}
src_compile() {
emake -C nvtool CC="$(tc-getCC)"
}
src_install() {
dobin nvtool/tpm-nvtool
}