blob: caf73bf379cddf103e4c4d7b1c1890a17eb548ef [file] [log] [blame]
# Copyright (c) 2011 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b05e4a6b92b2cfe608b6cd8d5d37168680fc080e"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "25b90cd13b01122d778a1d55d814c5b001b88d22" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_SUBTREE="common-mk smogcheck .gn"
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_OUTOFTREE_BUILD="1"
inherit cros-common.mk cros-sanitizers cros-workon cros-debug
DESCRIPTION="TPM SmogCheck library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/smogcheck/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="-asan"
src_unpack() {
cros-workon_src_unpack
S+="/smogcheck"
}
src_configure() {
sanitizers-setup-env
cros-common.mk_src_configure
}
src_install() {
emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
}