blob: 1d54385fe546974411b06ac338d4835d0af13a41 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# This is used to break a circular dependency caused by tests.
CROS_RUST_REMOVE_DEV_DEPS=1
CROS_RUST_SUBDIR="sirenia/libsirenia/sirenia-rpc-macros"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_SUBTREE="${CROS_RUST_SUBDIR}"
inherit cros-workon cros-rust
DESCRIPTION="Macros for generating the RPC implementation for Sirenia."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/sirenia/libsirenia/sirenia-rpc-macros"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
=dev-rust/proc-macro2-1*:=
=dev-rust/quote-1*:=
=dev-rust/syn-1*:=
"
# cros-rust_src_compile isn't used because it builds the unit tests.
src_compile() {
ecargo_build
}
# The tests are run in libsirenia since they depend on libsirenia which depends
# on this ebuild.
src_test() { :; }