blob: b3a3e39e8e64652db344c1dc2d5790a4a854bceb [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk shill .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="shill/client"
inherit cros-workon platform
DESCRIPTION="Shill DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/shill/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="~*"
IUSE="cros_host"
RDEPEND="
!<chromeos-base/shill-0.0.2
"
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "shill"
}