blob: cf7aef792c2c38471410dcc9a7c928399dbf6841 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="719d7ad1c3c6451d4ee1e50f33bf032e0f2fecd2"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "87425e8ce0b739c39c6e03febd179b9d850ad295" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk screen-capture-utils .gn"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
PLATFORM_SUBDIR="screen-capture-utils"
inherit cros-workon platform
DESCRIPTION="Utilities for screen capturing"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/screen-capture-utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Mark the old screenshot package as blocker so it gets automatically removed in
# incremental builds.
RDEPEND="
!chromeos-base/screenshot
media-libs/libpng:0=
media-libs/minigbm:=
x11-libs/libdrm:=
virtual/opengles"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers"
src_install() {
dosbin "${OUT}/screenshot"
}