blob: 632ecbcea5cfaeefe7f2765dc6705fda669ad308 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="c62f55d2cdf3e409b1d0094880444e80b3572c59"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "ed310628c7b59ac5528ea8347990fc4f5e95c915" "bcebcb36c5f685f0a530a8b411d7ffe49de01240" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk libcontainer run_oci .gn"
PLATFORM_SUBDIR="run_oci"
inherit cros-workon libchrome platform
DESCRIPTION="Utility for running OCI-compatible containers"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
COMMON_DEPEND="
chromeos-base/libcontainer:=
sys-apps/util-linux:=
sys-libs/libcap:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
src_install() {
cd "${OUT}"
dobin run_oci
}
platform_pkg_test() {
local tests=(
container_config_parser_test
run_oci_test
)
local test_bin
for test_bin in "${tests[@]}"; do
# platform_test takes care of setting up your test environment
platform_test "run" "${OUT}/${test_bin}"
done
}