blob: 58494b4948ee62293a2532c11845be41025d2d9e [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="18251f9fcb5317db6f3578c1ddbc01c53bef1686"
CROS_WORKON_TREE="8c66061f71ff3187484ec4cfa8c86320c90cfdb4"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="regions"
PLATFORM_SUBDIR="regions"
inherit cros-workon
DESCRIPTION="Chromium OS Region Data"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/regions/"
LICENSE="BSD-Google"
KEYWORDS="*"
# 'jq' allows command line tools to access the JSON database.
RDEPEND="app-misc/jq"
DEPEND=""
src_unpack() {
cros-workon_src_unpack
S+="/regions"
}
src_compile() {
./regions.py --format=json --output "${WORKDIR}/cros-regions.json"
}
src_test() {
./regions_unittest.py
}
src_install() {
dobin cros_region_data
insinto /usr/share/misc
doins "${WORKDIR}/cros-regions.json"
}