blob: cd35e57c0c13dcf9864a2044715af4cade2b33f9 [file] [log] [blame]
# Copyright (c) 2011 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="6e511de8901a322f54054e0f2885f1654ec49972"
CROS_WORKON_TREE="f4b9ec28863b19d383a13538b72050113cea51cc"
CROS_WORKON_PROJECT="chromiumos/platform/crostestutils"
CROS_WORKON_LOCALNAME="crostestutils"
CROS_WORKON_SUBTREE="recover_duts"
inherit cros-workon
DESCRIPTION="Test tool that recovers bricked Chromium OS test devices"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/crostestutils/+/master/recover_duts/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
RDEPEND="
chromeos-base/chromeos-init
"
DEPEND=""
src_unpack() {
cros-workon_src_unpack
S+="/recover_duts"
}
src_install() {
dosbin reload_network_device
exeinto /usr/libexec/recover-duts
newexe recover_duts.sh recover_duts
exeinto /usr/libexec/recover-duts/hooks
doexe hooks/*
}