blob: 8722575a99587d0d1b40945ff2f2b4aef4b60333 [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
CROS_WORKON_COMMIT="44b2e16939185c9a3ecca057eeccc2f4c47a6481"
CROS_WORKON_TREE="2a249f0f3fca6ab3c82d86616802086874f5c901"
CROS_WORKON_PROJECT="chromiumos/platform/mttools"
CROS_WORKON_LOCALNAME="platform/mttools"
inherit cros-sanitizers cros-workon cros-common.mk cros-constants cros-debug
DESCRIPTION="Chromium OS multitouch utilities"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/mttools"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan"
# This package has no tests.
RESTRICT="test"
RDEPEND="chromeos-base/gestures
app-misc/utouch-evemu
chromeos-base/libevdev
chromeos-base/touch_firmware_test"
DEPEND=${RDEPEND}
src_configure() {
sanitizers-setup-env
cros-common.mk_src_configure
}
src_install() {
# install to autotest deps directory for dependency
emake DESTDIR="${D}${AUTOTEST_BASE}/client/deps/touchpad-tests/framework" install
}