blob: 2fefdfd399dd326417013397aece8f41c56be1d8 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk minios .gn"
PLATFORM_SUBDIR="minios"
inherit cros-workon platform
DESCRIPTION="The miniOS main logic."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/minios/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="minios"
REQUIRED_USE="minios"
RDEPEND=""
DEPEND=""
platform_pkg_test() {
platform_test "run" "${OUT}/minios_test"
}
src_install() {
dobin "${OUT}/minios"
}