blob: 7b9e7370c8ae6b9598a74c67ba1ef5fa6d81513e [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Remove libmems from this list.
CROS_WORKON_SUBTREE="common-mk iioservice libmems .gn"
PLATFORM_SUBDIR="iioservice/iioservice_simpleclient"
inherit cros-workon platform
DESCRIPTION="A simple client to test iioservice's mojo IPC for Chromium OS."
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
RDEPEND="
chromeos-base/libiioservice_ipc:=
chromeos-base/libmems:=
"
DEPEND="${RDEPEND}
chromeos-base/system_api:=
"
src_install() {
dosbin "${OUT}"/iioservice_simpleclient
}