blob: 367cb716cff9c20453c1d1232e27dd60a50d7bf0 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="74a18769fbd5903778ea23c3be2db076c01b4dec"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "871fd3a6dccaf2c2099f6200b55691f4ce8f07cb" "fd9664c67f7b5bf90e85d620439201bab8f5ba3a" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Remove libmems from this list.
CROS_WORKON_SUBTREE="common-mk iioservice libmems .gn"
PLATFORM_SUBDIR="iioservice/iioservice_simpleclient"
inherit cros-workon platform
DESCRIPTION="A simple client to test iioservice's mojo IPC for Chromium OS."
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND="
chromeos-base/libiioservice_ipc:=
chromeos-base/libmems:=
"
DEPEND="${RDEPEND}
chromeos-base/system_api:=
"
src_install() {
dosbin "${OUT}"/iioservice_simpleclient
}