blob: 80175cb076ca23b0276390b71a8c18719e2b09de [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="d590e8a01b2514eecc78cb101a7ce85fe9c36fa4"
CROS_WORKON_TREE=("e2d4b5c2a34733c2112e0a9a8d0a2171f90ec316" "52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "e032004ea0f80ca4d1d9b01cebb46311ac2d8b33" "20ed8021024637e492670d20fa5969a2ad75e4b6" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="attestation common-mk hwsec-test-utils trunks .gn"
PLATFORM_SUBDIR="hwsec-test-utils"
inherit cros-workon platform
DESCRIPTION="Hwsec-related test-only features. This package resides in test images only."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/hwsec-test-utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="test tpm tpm2"
REQUIRED_USE="tpm2? ( !tpm )"
RDEPEND="
tpm2? (
chromeos-base/trunks:=
)
!tpm2? (
app-crypt/trousers:=
)
"
DEPEND="${RDEPEND}
tpm2? (
chromeos-base/trunks:=[test?]
)
chromeos-base/attestation:=
chromeos-base/system_api:=
dev-libs/openssl:=
dev-libs/protobuf:=
"
src_install() {
# Installs attestation-injected-keys
dobin "${OUT}/attestation-injected-keys"
# Installs hwsec-test-va
dobin "${OUT}/hwsec-test-va"
# Install fake pca agent
dobin "${OUT}"/fake_pca_agentd
}
platform_pkg_test() {
platform_test "run" "${OUT}/hwsec-test-utils_testrunner"
}