blob: dfd3ce9d6497dade59478e02ce8693f92625218b [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk goldfishd .gn"
PLATFORM_SUBDIR="goldfishd"
inherit cros-workon platform
DESCRIPTION="Android Emulator Daemon for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/goldfishd/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="~*"
RDEPEND="
chromeos-base/autotest-client
"
src_install() {
dobin "${OUT}"/goldfishd
insinto /etc/init
doins init/*.conf
}
platform_pkg_test() {
platform_test "run" "${OUT}/goldfishd_test_runner"
}