blob: 1a179b38a2dfe7fead70fb9e876121eea7c99b56 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b05e4a6b92b2cfe608b6cd8d5d37168680fc080e"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "ef83a68e71f0fc4deac90a21a6a5e93412707ca8" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_USE_VCSID=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk easy-unlock .gn"
PLATFORM_SUBDIR="easy-unlock"
inherit cros-workon platform user
DESCRIPTION="Service for supporting Easy Unlock in Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/easy-unlock/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
COMMON_DEPEND="
chromeos-base/easy-unlock-crypto:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="
${COMMON_DEPEND}
chromeos-base/system_api:=
"
pkg_preinst() {
enewuser easy-unlock
enewgroup easy-unlock
}
src_install() {
exeinto /opt/google/easy_unlock
doexe "${OUT}/easy_unlock"
insinto /etc/dbus-1/system.d
doins org.chromium.EasyUnlock.conf
insinto /usr/share/dbus-1/system-services
doins org.chromium.EasyUnlock.service
insinto /etc/init
doins init/easy-unlock.conf
insinto /usr/share/dbus-1/interfaces
doins dbus_bindings/org.chromium.EasyUnlockInterface.xml
}
platform_pkg_test() {
platform_test "run" "${OUT}/easy_unlock_test_runner"
}