blob: cd45c2de1d388e4223f6b730ac9f53e3e9316371 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="2d4bfe07dbbf6ce72542ee79545ce618699fdb78"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "ec13f3a8d1478fae9ae8f5e2d35ec77d97c81901" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk cryptohome .gn"
PLATFORM_SUBDIR="cryptohome/client"
inherit cros-workon platform
DESCRIPTION="Cryptohome D-Bus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/cryptohome"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="cros_host"
# D-Bus proxies generated by this client library depend on the code generator
# itself (chromeos-dbus-bindings) and produce header files that rely on
# libbrillo library, hence both dependencies.
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
RDEPEND="
!<chromeos-base/cryptohome-0.0.1
"
src_install() {
# Install D-Bus client library.
platform_install_dbus_client_lib "cryptohome"
}