blob: 2f5ae3a264b54aba029562c15ac46849f019ee4a [file] [log] [blame]
# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME="dev"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="host"
inherit cros-workon
DESCRIPTION="Development utilities for ChromiumOS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/+/HEAD/host/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
RDEPEND="app-portage/gentoolkit
>=chromeos-base/devserver-0.0.2
dev-lang/python
dev-util/shflags
dev-util/toolchain-utils
sys-apps/flashmap
"
# These are all either bash / python scripts. No actual builds DEPS.
DEPEND=""
src_compile() { :; }
src_install() {
local host_tools=(
cros_workon_make
netboot_firmware_settings.py
)
dobin "${host_tools[@]/#/host/}"
# Repo and git bash completion.
insinto /usr/share/bash-completion
newins host/repo_bash_completion repo
dosym /usr/share/bash-completion/repo /etc/bash_completion.d/repo
dosym /usr/share/bash-completion/completions/git /etc/bash_completion.d/git
}