blob: 61255e91747120fada726f58775998d57a5ad0f0 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT=("9e422c3c05fdd324565049b09be27c446f9dc0ca" "72a3dd167c24a20a6df568d0c84c77dd45a6d2cf")
CROS_WORKON_TREE=("b4694ca5abc8c1be1000a1efe7a7bd8a02ddd856" "1d1c66467f1ce5e5b0117438c1c104b51f954f5d")
CROS_WORKON_PROJECT=(
"chromiumos/platform/ec"
"chromiumos/platform/ec"
)
CROS_WORKON_LOCALNAME=(
"platform/ec"
"platform/cr50"
)
CROS_WORKON_DESTDIR=(
"${S}/platform/ec"
"${S}/platform/cr50"
)
CROS_WORKON_EGIT_BRANCH=(
"master"
"cr50_stab"
)
CROS_WORKON_INCREMENTAL_BUILD=1
inherit cros-workon
DESCRIPTION="Exported headers from the embedded controller codebase."
HOMEPAGE="https://www.chromium.org/chromium-os/ec-development"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND=""
DEPEND=""
# No configuration or compilation necessary. This is a header only package.
src_configure() { :; }
src_compile() { :; }
src_install() {
dir_ec=${CROS_WORKON_DESTDIR[0]}
dir_cr50=${CROS_WORKON_DESTDIR[1]}
insinto /usr/include/trunks/cr50_headers/
doins "${dir_cr50}"/include/pinweaver_types.h
doins "${dir_cr50}"/include/u2f.h
doins "${dir_cr50}"/board/cr50/tpm2/virtual_nvmem.h
insinto /usr/include/chromeos/ec/
doins "${dir_ec}"/include/ec_commands.h
doins "${dir_ec}"/util/cros_ec_dev.h
}