blob: 41220cdd3ceaeaf452da32c0188cb80de8eb90d4 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-dbus-bindings .gn"
PLATFORM_SUBDIR="${PN}"
PLATFORM_NATIVE_TEST="yes"
inherit cros-workon platform
DESCRIPTION="Utility for building Chrome D-Bus bindings from an XML description"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/chromeos-dbus-bindings"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="~*"
IUSE=""
RDEPEND="
dev-libs/expat
sys-apps/dbus"
DEPEND="${RDEPEND}"
src_install() {
dobin "${OUT}"/generate-chromeos-dbus-bindings
}
platform_pkg_test() {
platform_test "run" "${OUT}/chromeos_dbus_bindings_unittest"
}