blob: 0a4bc6226de663a1f4fc42c771f0ba34dc733f4b [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b05e4a6b92b2cfe608b6cd8d5d37168680fc080e"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "cb0770fe9b162f3437511fca1b23395c2a4758e9" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_SUBTREE="common-mk cfm-dfu-notification .gn"
CROS_WORKON_DESTDIR="${S}/platform2"
PLATFORM_SUBDIR="cfm-dfu-notification"
inherit cros-workon platform
DESCRIPTION="Library to send firmware update notifications to CFM"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
RDEPEND=""
DEPEND="${RDEPEND}"
src_install() {
dolib.so "${OUT}"/lib/libcfm_dfu_notification.so
"${S}"/platform2_preinstall.sh "${PV}" "/usr/include/chromeos" "${OUT}"
insinto "/usr/$(get_libdir)/pkgconfig"
doins "${OUT}"/cfm-dfu-notification.pc
insinto "/usr/include/chromeos/cfm-dfu-notification"
doins ./*.h
}
platform_pkg_test() {
platform_test "run" "${OUT}"/cfm_dfu_notification_test
}