blob: 17e8a2e6019c2676eece54ee3d118b4dbd312e79 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="891275e43ab2ed3070c377dd889259604911e046"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "c9f42ec607fcaf0dc1770080e49f9705bf7c5301" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/vm/scripts/init/mount-media-dirs .gn"
inherit cros-workon
DESCRIPTION="Mount media directories on a mount point shared with ARCVM."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/vm/scripts/init/mount-media-dirs"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
chromeos-base/mount-passthrough
"
src_install() {
insinto /etc/init
doins arc/vm/scripts/init/mount-media-dirs/arcvm-mount-myfiles.conf
doins arc/vm/scripts/init/mount-media-dirs/arcvm-mount-removable-media.conf
}