blob: 68da3387da60d6d20613f9dc5bfb1bce00bd64cc [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b05e4a6b92b2cfe608b6cd8d5d37168680fc080e"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "870cb50e86dd81c388ef1d394f6a1c290dfe726d" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/container/appfuse .gn"
PLATFORM_SUBDIR="arc/container/appfuse"
inherit cros-workon platform user
DESCRIPTION="D-Bus service to provide ARC Appfuse"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/container/appfuse"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
sys-apps/dbus:=
sys-fs/fuse:=
"
DEPEND="${RDEPEND}
chromeos-base/system_api:=
"
BDEPEND="
virtual/pkgconfig
"
src_install() {
platform_install
}
pkg_preinst() {
enewuser "arc-appfuse-provider"
enewgroup "arc-appfuse-provider"
}
platform_pkg_test() {
platform test_all
}