blob: 042a1f78add18ca140cd4b27a85b9fbabc2b622a [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b05e4a6b92b2cfe608b6cd8d5d37168680fc080e"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "e79a39f8f3a26e740eca5db95629cfb2e5d434aa" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/apk-cache .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="arc/apk-cache"
inherit cros-workon platform
DESCRIPTION="Maintains APK cache in ARC."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/apk-cache"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="+seccomp"
RDEPEND="
chromeos-base/minijail
dev-db/sqlite:=
"
DEPEND="
dev-db/sqlite:=
"
src_install() {
insinto /etc/init
doins init/apk-cache-cleaner.conf
# Install seccomp policy file.
insinto /usr/share/policy
use seccomp && newins \
"seccomp/apk-cache-cleaner-seccomp-${ARCH}.policy" \
apk-cache-cleaner-seccomp.policy
dosbin "${OUT}/apk-cache-cleaner"
dobin "${OUT}/apk-cache-ctl"
dosbin apk-cache-cleaner-jailed
}
platform_pkg_test() {
platform_test "run" "${OUT}/apk-cache-cleaner_testrunner"
platform_test "run" "${OUT}/apk-cache-ctl_testrunner"
}