blob: 0c5098182a3c0e1da97bc607846cc8b5435b7ec6 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI="6"
CROS_WORKON_COMMIT="d290f731c4d623269bf6a259a351bf92eb5f4854"
CROS_WORKON_TREE=("aa81756947ecfdd38b22f42eed8eeafa40431079" "663c1accb23d479e49928219593b0f82d782ba9c" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk avtest_label_detect .gn"
inherit cros-sanitizers cros-workon cros-common.mk
DESCRIPTION="Autotest label detector for audio/video/camera"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/avtest_label_detect"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan v4l2_codec vaapi"
RDEPEND="vaapi? ( x11-libs/libva )"
DEPEND="${RDEPEND}"
src_unpack() {
cros-workon_src_unpack
S+="/avtest_label_detect"
}
src_configure() {
export USE_VAAPI=$(usex vaapi)
export USE_V4L2_CODEC=$(usex v4l2_codec)
sanitizers-setup-env
cros-common.mk_src_configure
}
src_install() {
# Install built tools
pushd "${OUT}" >/dev/null
dobin avtest_label_detect
popd >/dev/null
insinto /etc
doins "${S}"/avtest_label_detect.conf
}