blob: e1f0d7930d01d33e610f77c816c0eab87a9a6710 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d290f731c4d623269bf6a259a351bf92eb5f4854"
CROS_WORKON_TREE=("aa81756947ecfdd38b22f42eed8eeafa40431079" "ffb2f47956ef0968f7461744ad1e8098dbc6b37c" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/myfiles .gn"
inherit cros-workon
DESCRIPTION="Container to run Android's MyFiles daemon."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/myfiles"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="chromeos-base/mount-passthrough
!<chromeos-base/chromeos-cheets-scripts-0.0.2-r470
"
src_install() {
insinto /etc/init
doins arc/myfiles/arc-myfiles.conf
doins arc/myfiles/arc-myfiles-default.conf
doins arc/myfiles/arc-myfiles-read.conf
doins arc/myfiles/arc-myfiles-write.conf
}