blob: ba01e5b597ae9aefeaf54eb8a8accc3941027fa7 [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="ca55b587c04f31c7249fb4ea9c8553e8d798e2c4"
CROS_WORKON_TREE=("68cccc539fbe33f8d64139114fd750ea429b8e06" "579c396ab45a9873730f1bba9094fe08132a48a3" "431e8602137055191734ac82485233855e1950a6" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk login_manager/dbus_bindings login_manager/session_manager-client .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="login_manager/session_manager-client"
WANT_LIBCHROME="no"
inherit cros-workon platform
DESCRIPTION="Session manager (chromeos-login) DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/login_manager/"
LICENSE="BSD-Google"
KEYWORDS="*"
# Disable unittesting for client bindings.
RESTRICT="test"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
RDEPEND="
!<chromeos-base/chromeos-login-0.0.2
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "session_manager"
}