| # Copyright 2013 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_COMMIT="67750ca06a728f82392f850282601c507b010082" |
| CROS_WORKON_TREE=("bb65b69cc68a30dadfd32a8998e99a42bcf68d85" "2b612ef6b13d4571274e5591b6661b2a1e1eafd3" "69850abc71491801028a7cb0e2994c56744b43a9") |
| CROS_WORKON_PROJECT="chromiumos/third_party/kernel" |
| CROS_WORKON_LOCALNAME="kernel/v5.15" |
| CROS_WORKON_EGIT_BRANCH="chromeos-5.15" |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| # Narrow the workon scope to just files referenced by the turbostat |
| # Makefile: |
| # https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-4.14/tools/power/x86/turbostat/Makefile#12 |
| CROS_WORKON_SUBTREE="arch/x86/include/asm tools/include tools/power/x86/turbostat" |
| |
| inherit cros-sanitizers cros-workon toolchain-funcs |
| |
| HOMEPAGE="https://www.kernel.org/" |
| DESCRIPTION="Intel processor C-state and P-state reporting tool" |
| |
| LICENSE="GPL-2" |
| SLOT="0/0" |
| KEYWORDS="*" |
| IUSE="-asan" |
| |
| RDEPEND="sys-libs/libcap:=" |
| |
| DEPEND="${RDEPEND}" |
| |
| domake() { |
| emake -C tools/power/x86/turbostat \ |
| BUILD_OUTPUT="$(cros-workon_get_build_dir)" DESTDIR="${D}" \ |
| CC="$(tc-getCC)" "$@" |
| } |
| |
| src_configure() { |
| sanitizers-setup-env |
| default |
| } |
| |
| src_compile() { |
| domake |
| } |
| |
| src_install() { |
| domake install |
| } |