blob: fd86ea91f030d2061e0dbf76e3f204dea8d95aac [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="2d2b07c18fb5d1f660789a8f98e30834aaf9a62e"
CROS_WORKON_TREE=("543a53a98d305d293220d62009366d32b4a5dbbd" "4b8d3a8a1831dbbc1e56166555ae744e1d5e2844" "14bef451b7ad0643325f11123b1739433d3b9eb1" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk debugd/client debugd/dbus_bindings .gn"
PLATFORM_SUBDIR="debugd/client"
WANT_LIBCHROME="no"
inherit cros-workon platform
DESCRIPTION="Chrome OS debugd client library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/debugd/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
# Disable unittesting for client bindings.
RESTRICT="test"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "debugd"
}