| # Copyright 2015 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="6" |
| |
| CROS_WORKON_COMMIT=("dbb1136242ba822d539eaf11493f3b68815adb7f" "269b6fb8401617b85e2dff7ae8a7b0f97613e2cd") |
| CROS_WORKON_TREE=("60fa47aebd6ebfb702012849bd560717fceddcd4" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "9473949bc842cc166ac244567638b94150a97865") |
| inherit cros-constants |
| |
| CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/modp_b64") |
| CROS_WORKON_LOCALNAME=("../platform2" "../third_party/modp_b64") |
| CROS_WORKON_PROJECT=("chromiumos/platform2" "aosp/platform/external/modp_b64") |
| CROS_WORKON_SUBTREE=("common-mk .gn" "") |
| CROS_WORKON_EGIT_BRANCH="master" |
| |
| PLATFORM_SUBDIR="modp_b64" |
| |
| WANT_LIBCHROME=no |
| |
| inherit cros-fuzzer cros-sanitizers cros-workon platform |
| |
| DESCRIPTION="Base64 encoder/decoder library." |
| HOMEPAGE="https://github.com/client9/stringencoders" |
| |
| LICENSE="BSD" |
| SLOT="0" |
| KEYWORDS="*" |
| IUSE="fuzzer" |
| |
| src_install() { |
| dolib.a "${OUT}"/libmodp_b64.a |
| |
| insinto /usr/include |
| doins -r modp_b64 |
| |
| insinto "/usr/$(get_libdir)/pkgconfig" |
| doins "${OUT}/obj/modp_b64/libmodp_b64.pc" |
| |
| local fuzzer_component_id="1034879" |
| fuzzer_install "${S}/OWNERS.fuzzer" "${OUT}"/modp_b64_decode_fuzzer \ |
| --comp "${fuzzer_component_id}" |
| fuzzer_install "${S}/OWNERS.fuzzer" "${OUT}"/modp_b64_encode_fuzzer \ |
| --comp "${fuzzer_component_id}" |
| } |