blob: b2b492b5993e32dc1724a951def86f683794ff48 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/tools/connector_client camera/common camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/tools/connector_client"
inherit cros-camera cros-workon platform
DESCRIPTION="A simple package that exercises cros-camera-libcamera_connector"
LICENSE="BSD-Google"
KEYWORDS="~*"
RDEPEND="chromeos-base/cros-camera-libs"
DEPEND="${RDEPEND}
x11-libs/libdrm"
BDEPEND="virtual/pkgconfig"
src_install() {
platform_src_install
dobin "${OUT}/cros_camera_connector_client"
}