blob: f98c51ec8c0407ac6d6ff19d3d3b427fa58b466a [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "92e357708a584d0da1efabfdc10b432c2bfc40c9" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk touch_firmware_calibration .gn"
PLATFORM_SUBDIR="touch_firmware_calibration"
inherit cros-workon platform user udev
DESCRIPTION="Touch Firmware Calibration"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/touch_firmware_calibration/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
pkg_preinst() {
# Set up touch_firmware_calibration user and group which will be used to
# run tools for calibration.
enewuser touch_firmware_calibration
enewgroup touch_firmware_calibration
}
src_install() {
# Install a tool to override max pressure.
exeinto "$(get_udevdir)"
doexe "${OUT}/override-max-pressure"
# Install the correct seccomp policy for this architecture.
insinto "/usr/share/policy"
newins "seccomp/override-max-pressure-seccomp-${ARCH}.policy" override-max-pressure-seccomp.policy
}