blob: 7e7585e0cdde13f15eb445d0a81225a017e5c557 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "ece498561dfd2919d08524f2ad5d5c60982feb4b" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk thd .gn"
PLATFORM_SUBDIR="thd"
inherit cros-workon platform user
DESCRIPTION="Thermal Daemon for Chromium OS"
HOMEPAGE="http://dev.chromium.org/chromium-os/packages/thd"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
pkg_preinst() {
enewuser thermal
enewgroup thermal
}
src_install() {
dobin "${OUT}"/thd
dodir /etc/thd/
insinto /etc/init
doins init/*.conf
}