blob: 3a65f4896d7c7641d60eaf18a22ae198d9404aca [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="common-mk shill/cli .gn"
PLATFORM_SUBDIR="shill/cli"
inherit cros-workon platform
DESCRIPTION="Shill Command Line Interface"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/shill/cli"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="~*"
IUSE=""
RDEPEND="
>=chromeos-base/shill-0.0.1-r2205
"
DEPEND="
chromeos-base/shill-client:=
chromeos-base/system_api:=
"
src_install() {
dobin "${OUT}"/shillcli
}
platform_pkg_test() {
platform_test "run" "${OUT}/shillcli_test"
}