blob: fdee56b576fe7fe71a9d235e97a207fa81112fe4 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk sealed_storage tpm_manager trunks .gn"
PLATFORM_SUBDIR="sealed_storage"
inherit cros-workon platform
DESCRIPTION="Library for sealing data to device identity and state"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/sealed_storage"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="test tpm2"
REQUIRED_USE="tpm2"
COMMON_DEPEND="
chromeos-base/tpm_manager:=[test?]
chromeos-base/trunks:=[test?]
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
chromeos-base/protofiles:=
chromeos-base/system_api:=
"
src_install() {
dosbin "${OUT}"/sealed_storage_tool
dolib.a "${OUT}"/libsealed_storage.a
dolib.so "${OUT}"/lib/libsealed_storage_wrapper.so
insinto /usr/include/chromeos/sealed_storage
doins sealed_storage.h
}
platform_pkg_test() {
platform_test "run" "${OUT}/sealed_storage_testrunner"
}