blob: 2d3306e5d3c71cef3dea6653e915da9b6ea8c030 [file] [log] [blame]
# Copyright (c) 2011 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk modem-utilities .gn"
PLATFORM_SUBDIR="modem-utilities"
inherit cros-workon tmpfiles platform
DESCRIPTION="Chromium OS modem utilities"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/modem-utilities/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="~*"
COMMON_DEPEND="
sys-apps/dbus:=
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
src_install() {
dobin modem
dobin connectivity
dobin config_net_log
exeinto /usr/lib
doexe modem-common.sh
doexe connectivity-common.sh
dotmpfiles tmpfiles.d/*.conf
}