blob: d9157c9b353f0292a08129c55d22673b766a739e [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="08aee9d7a91dddd5977b31ca2a2833ba54f8d89a"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "da73aae6d89c8e69c3740af612610792ce42b1a8" "359903647899af99fb1bc9ba9d666b0e78fcb3a8" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Remove libmems from this list.
CROS_WORKON_SUBTREE="common-mk iioservice libmems .gn"
PLATFORM_SUBDIR="iioservice/iioservice_simpleclient"
inherit cros-workon platform
DESCRIPTION="A simple client to test iioservice's mojo IPC for Chromium OS."
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND="
chromeos-base/libiioservice_ipc:=
chromeos-base/libmems:=
"
DEPEND="${RDEPEND}
chromeos-base/system_api:=
"
src_install() {
dosbin "${OUT}"/iioservice_simpleclient
}