blob: 851f9cf70443465d7aa498710dfa0e2ca3f637b4 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk feedback .gn"
PLATFORM_SUBDIR="feedback"
inherit cros-constants cros-workon git-2 platform
DESCRIPTION="Feedback service for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/feedback/"
LICENSE="BSD-Google"
KEYWORDS="~*"
RDEPEND=""
DEPEND="chromeos-base/system_api:="
src_install() {
dobin "${OUT}"/feedback_client
dobin "${OUT}"/feedback_daemon
insinto /etc/init
doins init/feedback_daemon.conf
insinto /etc/dbus-1/system.d
doins org.chromium.feedback.conf
insinto /usr/include/feedback
doins components/feedback/feedback_common.h
doins feedback_service_interface.h
}
platform_pkg_test() {
local tests=(
feedback_daemon_test
)
local test_bin
for test_bin in "${tests[@]}"; do
platform_test "run" "${OUT}/${test_bin}"
done
}