blob: 13625a5dc64b801a27c00418f3782ef783334233 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="7198886aa352d29ae07eea8ca3e25094e14c8189"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "d58be6324ba2a1d0452d23bafb39c869c5ed2cd6" "b99d8a0b7d7f0e2f844af457f29d449cdd953d43" "584f7cc8998d8fa6c9b041054ce4a352016f477a" "84441b28a7584715021e2faf292e0cf5864ea8bf" "eec5ce9cfadd268344b02efdbec7465fbc391a9e" "7e189936f29d145c4191ea147e48256c92fac75d")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/include camera/mojo common-mk metrics"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/common/jpeg/libjda"
inherit cros-camera cros-workon platform
DESCRIPTION="Library for using JPEG Decode Accelerator in Chrome"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
RDEPEND="
media-libs/cros-camera-libcamera_common
media-libs/cros-camera-libcamera_ipc"
# cros-camera-libcbm is needed here because this package uses
# //camera/common:libcamera_metrics rule. It doesn't directly use the package,
# but another rule in that BUILD.gn requires libcbm upon opening the .gn file.
# See crbug.com/995162 for detail.
DEPEND="${RDEPEND}
chromeos-base/metrics
media-libs/cros-camera-libcbm
media-libs/libyuv
virtual/pkgconfig"
src_install() {
dolib.a "${OUT}/libjda.pic.a"
cros-camera_doheader ../../../include/cros-camera/jpeg_decode_accelerator.h
cros-camera_dopc ../libjda.pc.template
}